phone echoes

bencb44

New member
Offline
As far as I know, this has just recently started happening. People on the other end of a call can hear a very loud echo of what they say. I can hear an echo of myself sometimes, but for about the last week, everyone I've talked to has complained about the echo.

Does anyone have an ideas on what is going on, or how to fix it?

I don't know if it matters, but I have the ATR 3.0 ROM. Would, maybe, a different ROM help?
 
J

jdep1

Offline
its really interesting i never had a problem like this.. i would think it has to do w/ the network you are on. my bro had a problem almost like yours & he had sprint but he had a phone flash to work with sprint. so i hope some one could give you a better answer
 

bencb44

New member
Offline
So what exactly is the radio? I've heard it mentioned a few times, but I have no idea what it actually is. Is it like the actual program that's responsible for managing the connection to the network?

--------- New Post Merged on 9/8/2009 at 08:32:37 --------

OK, nevermind. I posted that last one before looking over at the radio thread thingy. I'll give it a try. Thanks a ton.
 
Last edited:

D/\SH

Member
Offline
that can happen mainly due to low signal strength... but can also happen when you are jumping from good signal to bad signal a lot... but also att he same time vibration (as if the usb port was loose) can knock loose the solder of part you talk into causing it to move thus creating an echo... so if your device has been dropped recently that could very well be that.
 

bencb44

New member
Offline
Is there any way to visually check to see if something is loose? This is a replacement phone I just recently got from Sprint. I did drop it, but it was about a foot and a half into soft dirt. Could that've been enough force to break it?
 

D/\SH

Member
Offline
Is there any way to visually check to see if something is loose? This is a replacement phone I just recently got from Sprint. I did drop it, but it was about a foot and a half into soft dirt. Could that've been enough force to break it?

dont know depends on how it feel, how hard, if it hit with all force to a pebble or rock etc...... and to viuslaly check you would have to take the device apart and look a tthe board to make sure the solders are broke.
 

bencb44

New member
Offline
Ok, I think it might be from the drop. I gently shook the phone a little while ago, and I can hear something loose around the bottom of the phone (by the microphone). Could something loose down there be causing this? Why would the person talking to me hear an echo of what they said?

So I guess this brings up another question: how durable is this phone, really? This'll be the second time I've had to replace it in just a couple months. I'm already trying to be careful with it. Should I just expect it to break frequently?

Thanks for all the help.
 

D/\SH

Member
Offline
Ok, I think it might be from the drop. I gently shook the phone a little while ago, and I can hear something loose around the bottom of the phone (by the microphone). Could something loose down there be causing this? Why would the person talking to me hear an echo of what they said?

So I guess this brings up another question: how durable is this phone, really? This'll be the second time I've had to replace it in just a couple months. I'm already trying to be careful with it. Should I just expect it to break frequently?

Thanks for all the help.


i havent had troubles or broke one of my touch pros (returned one due to recall) and they have been sturdy for me... could jst be the batch that you got, and the reason it would echo for them and not you is because its just free vibrating since detached partially which will cause the vibration to muffle or echo the voice.
 

littledaisy

SPJ Addict :)
Offline
Ok, thanks for the help. I was hoping I didn't have to send it in. I just got one of those invisible shield things from zagg.com. I hate wasting money like that.

well before sending it in why not try flashing a new radio...maybe that fixes the echo problem..just a thought...but good luck on getting that resolved. :)
 

bencb44

New member
Offline
Yeah I'm gonna try that. I talked to someone a little bit ago and they didn't hear an echo at all, so I'm thinking it might be the radio and not the phone being broken. I even asked them if they could hear it and they didn't, so that brings me a little hope.
 

littledaisy

SPJ Addict :)
Offline
yeah i think the radio will most likely do it for you :) i would recommend the latest sprint radio..seems to be working for a lot of people.. :)
 

D/\SH

Member
Offline
Yeah I'm gonna try that. I talked to someone a little bit ago and they didn't hear an echo at all, so I'm thinking it might be the radio and not the phone being broken. I even asked them if they could hear it and they didn't, so that brings me a little hope.
where are you located and i could tell you what many around there run successfully..... and keeping my fingera crossed trhat it aintt hre aspeaker and is the radio and your reception.
 

bencb44

New member
Offline
I'm in Eugene, OR.

--------- New Post Merged on 11/8/2009 at 12:25:18 --------

Wow, I am a freaking idiot. I've just spent the last half hour or so looking for my data connect cable thingy before I remembered that it plugs into the wall charger.
 
Last edited:

littledaisy

SPJ Addict :)
Offline
hmm...Oregon...well if the sprint radio doesnt do it you can also try the Telus radio since ur pretty close to canada...i used it for a while and thought it was great and im in southern california..so yeah...good luck with everything :) :thumb:
 

bencb44

New member
Offline
Just installed the new sprint radio and tried calling from my home phone. It still echoes about the same. So I guess it really is broken again. Thanks for all the help.
 

D/\SH

Member
Offline
I'm in Eugene, OR.

--------- New Post Merged on 11/8/2009 at 12:25:18 --------

Wow, I am a freaking idiot. I've just spent the last half hour or so looking for my data connect cable thingy before I remembered that it plugs into the wall charger.

Just installed the new sprint radio and tried calling from my home phone. It still echoes about the same. So I guess it really is broken again. Thanks for all the help.

mmm odesnt mean that, whats your majot provider out around your area.... like the one that gets the best reception... is it alltel, verizon, sprint, you can try telus, uscellular, etc.
 

bencb44

New member
Offline
Where I'm testing it, I have four bars. I don't know who the major provider is here. I know a lot of people who use Sprint, att, and Verizon.
 
Top